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Freie Geodaten aus dem Netz

OpenStreetmap 
http://www.openstreetmap.org/

OpenStreetmap-Online-Karte: Datenexport über reiter-Export
http://download.geofabrik.de/osm/europe/germany/

Aktuelle OSM-Daten im nativen OSM-Format (*.osm.bz2 entpackt zu *.osm) 
sowie als Shapefile mit reduzierten Objektklassen.

Corine Landcover
http://www.corine.dfd.dlr.de/intro_de.html

Landnutzungsdaten des europäischen CORINE-Projektes

Quellen für freie Geodaten

Administrative Grenzen als Shapefile -weltweit und andere Geodaten
http://www.gadm.org/

http://www.diva-gis.org/Data
Diverse frei verfügbare Geodaten

SRTM-X-Band Daten (Höhendaten, besser auflösend als SRTM)
http://eoweb.dlr.de:8080/index.html

SRTM: Weltweite Höhendaten
http://netgis.geo.uw.edu.pl/srtm/Europe/ oder

http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/
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Online Dienste WMS und WFS

WFS-Server (Web-Feature-Service)
 (Vektorfeature werden übers Netz ins GIS geladen und können wie gewöhnliche Vektorlayer abgefragt und 

symbolisiert sowie  als Shape etc. abgespeichert werden)
Zugriff über QGIS: Layer > WFS-Server hinzufügen

Beispiel: Naturschutzgebiete Rheinland-Pfalz  (URL über  Layer > WFS-Server hinzufügen : Neu in qgis eintragen)
http://map1.naturschutz.rlp.de/service_lanis/mod_wfs/wfs_getmap.php?mapfile=naturschutzgebiet

WMS-Server (Web-Map-Service)
(Rasterbasierender Internet-Kartenservice)

Zugriff über QGIS: Layer > WMS-Server hinzufügen
WMS-Server lassen sich hinzufügen und die Layer laden. Auswahl des KBS ist möglich.

Schaltfläche neu: Server zur Liste hinzufügen
Anzeigen der WMS-Legende erfordert Installation der Erweiterung CSI WMS Legend:

Erweiterungen > Python-Erweiterungen herunterladen > Reiter: Repositorien
URL: http://osgis.csi.it/qgis_plugin/csi_plugin_test.htm hinzufügen

Reiter Erweiterungen: CSI WMS Legend installieren

Deutschland (URL über  Layer > WMS-Server hinzufügen : Neu in qgis eintragen)
http://wms1.ccgis.de/cgi-bin/mapserv?map=/data/umn/germany/germany.map&&VERSION=1.1.1&REQUEST=GetCapabilities&SERVICE=WMS

http://ims1.bkg.bund.de/bund/servlet/gtEntryPoint?

Hessen  (URL über  Layer > WMS-Server hinzufügen : Neu in qgis eintragen)
http://www.gds-srv.hessen.de/cgi-bin/lika-services/ogc-free-maps.ows?

Übersicht über diverse Server
(http://www.skylab-mobilesystems.com/ger/wms_serverlist.html)

http://osgis.csi.it/qgis_plugin/csi_plugin_test.htm
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Nutzung von Google-Luftbildern in QGIS

Erweiterung OpenLayers

Mit der Erweiterung Openlayers lassen sich Google-Luftbilder direkt ins Programm laden. 
Die Bildausschnitte lassen sich als georeferenzierte Luftbildmosaike speichern.
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Nutzung von Google-Luftbildern in QGIS

Erweiterung OpenLayers

Mit der Erweiterung Openlayers lassen sich Google- und 
OpenStreetmap-Daten  direkt in die Kartenansicht laden. 

Die Bildausschnitte lassen sich mit Hilfe verschiedener Werkzeuge als 
georeferenzierte Luftbildmosaike speichern.

Openlayers-Plugin installieren
Erweiterungen > Python-Erweiterungen herunterladen

Zum Reiter Erweiterungen  wechseln:
In die Filter-Zeile OpenLayers schreiben

OpenLayers-Plugin installieren
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Nutzung von Google-Luftbildern in QGIS

Laden Sie das Shapefile GEBIETSGRENZE

Laden Sie anschließend das Satelitenbild mit dem Menüaufruf
Erweiterungen > OpenLayersPlugin > Google Satelite Layer

Wenn nichts angezeigt wird ZOOMEN Sie auf die Gebietsgrenze
Layer > auf Layerausdehnung zoomen

anschließend über Ansicht > hineinzoomen 
mit der Maus in den gewünschten Bereich zoomen

Google-Satelitenbild über die Erweiterung OpenLayers laden

Hinweis: OpenLayers stellt das Koordinatensystem um!
Das KBS auf „Projiziert > Mercator > WGS84 PseudoMercator“ gesetzt

Gleichzeitig wir die „On the Fly KBS-Transformation“ aktiviert!
Somit werden alle geladenen Layer bezogen auf die Google-Layer projiziert!
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Nutzung von Google-Luftbildern in QGIS

Hochauflösendes Luftbild aus Google-Satelitenbild exportieren
Mit

Datei > Bild speichern als
lässt sich die jeweilige Ansicht als georeferenziertes Bild speichern.

Um ein hochauflösendes Bild zu erreichen, zoomt man weit in die Ansicht hinein
und speichert jeweils kleine Auschnitte, die später zusammengefügt werden!

Die Ausschnitte lassen sich einfacher wählen, 
wenn man sich vorher ein Vektorraster anlegt

Vektor > Forschungswerkzeuge > Vektoraster

Messen Sie vorher aus, wie groß die Gitterzellen sein müssen, 
um einen Ausschnitt in der von Ihnen benötigten Auflösung zu erzeugen

Je nach Bildschirm und gewünschter Auflösung kann z.B.
eine Ausdehnung von 100 x 75 m sinnvoll sein.

Abgrenzung des Netzes
aus Ansicht oder Layergrenze

Größe der Gitterzellen in m
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Nutzung von Google-Luftbildern in QGIS

Hochauflösendes Luftbild aus Google-Satelitenbild exportieren

Laden Sie das neue Vektorraster, stellen Sie nur die Grenze ohne Flächenfarbe dar und 
beschriften den Layer nach der ID (Nummerierung)

(Siehe Folienscript QGIS-Basisfunktionen)

Anschließend können Sie die nummeriertem Zellen des Rasters als Orientierung nutzen und 

Mit
Datei > Bild speichern als

die Bildausschnitte als Tif-Datei speichern
Vor dem speichern die anderen Layer und die 

Dekorationen (Ansicht > Dekorationen) ausblenden, 
sonst haben Sie das Vektorraster und die Maßstabsleiste auf Ihrem fertigen Luftbild!

Als nächstes müssen Sie die gespeicherten Kacheln zusammenfügen, um Sie dann in ein 
beliebiges KBS (GK3, UTM etc.) umzuprojizieren!
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Nutzung von Google-Luftbildern in QGIS

Aus Google exportierte Luftbilder verschmelzen und umprojizieren

Anschließend projizieren Sie die neue Tif-Datei nach GK 3 um
Menüaufruf: Raster > Projektionen > Transformieren

Eingabedatei: Das virtuelle Raster, welches aus den einzelnen 
„Schnappschüssen erstellt wurde.
Ausgabedatei: jever_GK3.tif
Eingabe-KBS: 
Projiziertes Koordinatensys. > Mercator >  WGS84 PseudoMercator
Ausgabe-KBS: 
Projiziertes Koordinatensys. > Transverse Mercator >DHDN Gauß-Kruger 3

Fassen Sie die Bilder mit der Funktion Raster > Sonstiges > Virtuelles Raster erzeugen  (gdalbuildvrt) 
in einem virtuellen Raster (Rasterkatalog) zusammen (hohe Auflösung auswählen).

Wählen Sie als Eingabedatei die eben gespeicherten Bilddateien (mit der Maus und gleichzeitig gedrückter STRG-Taste 
anklicken oder Verzeichnis auswählen) aus und nennen Sie die Ausgabedatei ges.vrt

 Jetzt verfügen Sie über ein hochauflösendes
Luftbild im GK3-KBS, allerdings bei großem Speicherbedarf

In ein anderes Dateiformat konvertieren z.B. JPG (kleine Dateigröße):
Menüaufruf: Raster > Konvertierung > übersetzen (gdal-translate)
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OpenStreetmap-Daten nutzen

OpenStreetMap ist ein Projekt mit dem Ziel, 
frei verfügbare Geodaten zu sammeln oder zu erfassen und jedem Interessieren zur Verfügung zu stellen

Aus den Daten lassen sich thematische Karten rendern, 
die über das Web oder andere Wege publiziert werden können.

OSM publiziert eine eigene Karte über den Webbrowser
http://www.openstreetmap.de oder http://www.openstreetmap.org

Sowohl die gerenderten Karten als auch die Daten sind frei verfügbar, lizensiert unter der
Open Data Commons Open Database License (ODbL)

OpenStreetmap-Daten 

OpenStreetmap-Karten ins GIS laden

Verschiedene OSM-Karten lassen sich mit der Erweiterung OpenLayers wie die Google-Luftbilder ins QGIS 
laden. Auch im ArcGis gibt es diese Möglichkeit

Menüaufruf
QGIS: Erweiterungen > OpenlayersPlugin > OpenStreetmapLayer etc. hinzufügen

ArcGis: Daten > Daten hinzufügen > Grundkarten hinzufügen
Der Bildschirminhalt lässt sich wie bei Thema Google beschrieben, als georeferenziertes Bild speichern

Im QGIS sind über OpenLayers neben der Standard OSM-Karte folgende Themen verfügbar
OpenCycleMap

OCM PublicTransport
OCM Landscape

http://www.openstreetmap.de/
http://www.openstreetmap.org/
http://opendatacommons.org/licenses/odbl/
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OpenStreetmap-Daten nutzen

Beispielkarte aus dem Webbrowser
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OpenStreetmap-Daten nutzen

Beispielkarte aus dem Webbrowser
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OpenStreetmap-Daten nutzen

OSM-Daten in ArcGis laden
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OpenStreetmap-Daten nutzen

Menüaufruf
Erweiterungen > OpenlayersPlugin > OpenStreetmap hinzufügen

Anschließend auf das gewünschte Gebiet zoomen (z.B. mit Hilfe eines geladenen Shapes)

OSM mit OpenLayers visualisieren

Die über das Web verfügbaren Karten werden aus den, in einem offenen XML-Format 
veröffentlichten Daten gerendert. Diese Daten sind frei verfügbar und lassen sich im GIS nutzen.

Insbesondere Straßen, Wege, Waldflächen und Gewässer sind gut erfasst. 
In manchen Gebieten auch andere Flächennutzungen und Gebäude.
Stadtpläne aus OSM-Daten sind meist sehr detailreich und präzise.

Die XML-Daten (*.OSM) lassen sich für kleinere Gebiete direkt aus dem Netz 
ins QGIS laden oder über einen Webbrowser herunterladen.

Vor dem Herunterladen der Daten zoomen Sie auf das gewünschte Gebiet und setzen 
unter: Einstellungen > Projekteinstellungen >Koordinatenbezugssystem

das Kreuzchen bei „On the Fly KBS-Transformation aktivieren“

Anschließend: Menüaufruf:
Web > OpenStreetmap> OSM-Daten herunterladen

Small Scale angeben, „Daten nach dem laden automatisch öffnen“ ankreuzen

OpenStreetmap-Daten herunterladen
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Download OSM-Daten
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OpenStreetmap-Daten nutzen

Alternative: Download aus dem Webbrowser:http://www.openstreetmap.org/
Reiter: Export / Format: OpenStreetmap-XML-Dateien

In beiden Fällen wird eine Datei Name.osm auf der Festplatte gespeichert, die über den Menüaufruf
Web > OpenStreetmap > OSM aus datei laden zu öffnen ist.

jever.osm finden Sie als Beispieldatei
Ein Punkt-, ein Linien- (Straßen etc.) und ein Polygonlayer (Gebäude, Flächennutzung) werden angezeigt.

Die Daten werden thematisch visualisiert, für eine Weiterverarbeitung ist die 
Konvertierung in ein gis-gängiges Format (Shapefile, sqlite etc. notwendig)

Der OSM-Server erlaubt aktuell aus Kapazitätsgründen
nur eine Ausdehnung des Downloads von 0,25° in Geog. Länge und Breite

Daten ganzer Länder lassen sich über den Anbieter Geofabrik herunterladen
http://download.geofabrik.de/osm/europe/germany/

OpenStreetmap-Daten direkt ins QGIS laden

Menüaufruf
Layer > speichern als

KBS: DHDN GK3 / Format: ESRI-Shapefile oder Spatialite
Für SpatiaLite spricht, dass die Attribute der Spalte tags auch bei großer Länge nicht gekürzt werden.

Layer in die Ansicht laden!
Nur im Format Spatialite ist gewährleistet, dass die tags in voller Länge mitgenommen werden.

Die einzelnen Layer als Shapefile oder spatialite speichern

http://download.geofabrik.de/osm/europe/germany/
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OSM-Daten unklassifziert

KBS: WGS 84 – muss umprojiziert werden
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OpenStreetmap-Daten nutzen

Zum Datenformat

Die OSM-Daten werden in einem XML-Dateiformat ausgegeben, 
dass heißt die Daten stehen als Text in einer definierten XML-Syntax zur Verfügung. 

Die Syntax beschreibt GeoObjekte (Nodes, Ways, Relationen) und ihre Eigenschaften (tags). 
Nodes sind einzelne Punkte, deren Position in der Welt über geographische Koordinaten definiert werden. 

Sie verfügen über eine eindeutige ID, über Koordinaten 
(lat = Geog. Breite und lon = geog. Länge jeweils in Dezimalgrad z.B. lat="53.5763732" lon="7.8881323" )

 und können über Eigenschaften (tags) verfügen, wenn es sich um eigenständige Inhalte, 
wie z.B. eine Haltestelle handelt.

Ways fassen Nodes zu Linien- oder Polygon-Objekten (geschlossener Linienzug) zusammen. 
Die  Nodes werden über ihre IDs den Ways zugeordnet. 

Jeder Way enthält seinerseits eine ID und kann über Sacheigenschaften (tags) verfügen.

Relationen beschreiben komplizierte Objekte, wie z.b. Multipolygone und Polygone mit Löchern bzw. 
Polygone in Polygonen. Eine Relation besteht aus verschiedenen Ways, die innerhalb der Relation eine 
bestimmte Rolle spielen. Soll z.B. ein Teich inmitten eines Waldes erfasst werden, so ist das Ufer des 

Teichs zugleich der Rand des Waldes. Dieser geschlossene Linienzug (Way) beschreibt in der Relation 
Teich das Ufer und in der Relation Wald die Innengrenze. 
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OpenStreetmap-Datenformat

Nodes

<node>
<node id="30463017" lat="53.5763732" lon="7.8881323" user="GPS-Wolf" uid="38735" visible="true" 
version="4" changeset="3328371" timestamp="2009-12-08T21:28:52Z">
<tag k="highway" v="traffic_signals"/>
<node>

Dieser Node mit tags beschreibt eine Ampelanlage

<node id="30463010" lat="53.5763732" lon="7.8881323" user="GPS-Wolf" uid="38735" visible="true" version="4" 
changeset="3328371" timestamp="2009-12-08T21:28:52Z"/>

Node ohne tags

Eindeutige ID Geograph. Breite
in Dez.Grad

Geograph. Länge
in Dez.Grad Nutzer und NutzerID

tag beginn
Schlüssel (key) des tags

= highway
Value (Wert) des keys

= Traffic_signals

Erfassungszeitpunkt
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OpenStreetmap-Datenformat

Ways
Dieser Way mit tags beschreibt ein Gebäude

Eindeutige ID
des Ways

</way>
<way id="77867746" user="masju + Team" uid="292160" visible="true" version="1" changeset="5802123" timestamp="2010-09-17T09:45:57Z">

<nd ref="915352863"/>
<nd ref="915351027"/>
<nd ref="915354903"/>
<nd ref="915354337"/>
<nd ref="915352863"/>
<tag k="addr:country" v="DE"/>
<tag k="addr:city" v="Jever"/>
<tag k="addr:postcode" v="26441"/>
<tag k="addr:housenumber" v="6"/>
<tag k="addr:street" v="Am Woltersberg"/>
<tag k="building" v="yes"/>
</way>

Nutzer und
NutzerID

IDs der beteiligten Nodes:
Der erste und der letzte Node sind indentisch,

also ein Polygon mit fünf Eckpunkten

Verschiedene tags beschreiben die Eigenschaften des Polygons:

●in Deutschland
●In Jever

●PLZ: 25442
●Mit der Hausnummer 6

●in der Straße „Am Woltersberg“
●Ein Gebäude

Schlüssel (key) des tags
= building

Value (Wert) des keys
= yes
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OpenStreetmap-Datenformat

Relationen
Diese Relationen beschreiben einen Wald mit zwei Wiesen im inneren

</relation>
<relation id="1178363" user="masju + Team" uid="292160" visible="true" version="1" changeset="5785982" timestamp="2010-09-15T11:03:54Z">

<member type="way" ref="77616535" role="inner"/>
<member type="way" ref="77616536" role="inner"/>
<member type="way" ref="77616611" role="outer"/>
<tag k="type" v="multipolygon"/>
<tag k="landuse" v="forest"/>
</relation>
</relation>
<relation id="1178183" user="masju + Team" uid="292160" visible="true" version="1" changeset="5784819" timestamp="2010-09-15T08:44:22Z">
<member type="way" ref="77616535" role="outer"/>
<member type="way" ref="77616536" role="outer"/>
<tag k="type" v="multipolygon"/>
<tag k="landuse" v="meadow"/>
</relation>

Relation und
Relation ID

Drei Ways sind Mitglieder der Relation. 
Einer stellt diese Außengrenze  (role = „outer“) und zwei die 

Innengrenze der Löcher (role = „inner“) dar

Die tags beschreiben die Relation als
 Multipolygon und als Waldgebiet

Zwei Ways sind Mitglieder der Relation. 
Einer stellt diese Außengrenze des einen Lochs  (role = „outer“) und einer die 

Außengrenze des anderen Lochs dar (role = „outer“) dar. 
Es sind die gleichen Ways, die die Innengrenzen des Waldpolygons beschreiben.

Die tags beschreiben die Relation als
 Multipolygon und als Wiese
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OpenStreetmap-Daten nutzen

Die als Shapefile oder SpatiaLite gespeicherten Daten verfügen über eine Attributtabelle, 
in welche die Inhalte der tags eingetragen werden. Beim QGIS-Direktimport (Web > Openstreetmap) gibt es 

Einschränkungen bei komplexen Multpolygon-Relationen, so dass z.B.  komplexe Flächennutzungen (Wälder 
mit enthaltenen Gewässern, die wiederum Inseln enthalten), nicht vollständig importiert werden.

Als Alternative bietet sich der Import in eine PostGIS-Datenbank oder der Import über spatialite_osm_map .

Diese Vorgehensweise wird später beschrieben

Sie finden folgende Attributspalten vor.

Attribute nach QGIS-Direktimport

Attributspalte tags

In der Attributspalte tags finden Sie die tags des jeweiligen Objektes in der ursprünglichen Syntax und 
vollständigen Länge, wenn die Daten ins SpatiaLite-Format gespeichert wurden .

Im Shapefile-Format werden sehr lange Attribute abgeschnitten.

Weitere Attributspalten
Beim OSM-Import werden die tags ausgewertet und verschiedene thematische 

Attributspalten angelegt, die eine einfache Kategorisierung ermöglichen:
name, place, highway, landuse, waterway, railway, amenity, leisure, tourism, learning

Die Gebäude lassen sich nur aus der tags-Spalte extrahieren. 

Infos zu den Attributen (tags) in OSM:
http://wiki.openstreetmap.org/wiki/DE:Map_Features

http://wiki.openstreetmap.org/wiki/DE:Map_Features
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OpenStreetmap-Daten nutzen

Erläuterung der Attribute nach QGIS-Direktimport

tags: OSM-Attributierung in vollständiger Syntax
name: Eigennamen von Objekten zur Beschriftung (z.B. Staßennamen)
place: Plätze
highway: Kategorisierung von Straßen und Wegen 
landuse: Flächenhafte Landnutzung
waterway: Gewässer
railway: Schienenverkehr
amenity: Öffentliche Einrichtungen, private Dienstleistungen (Kindergarten, Tankstelle, Feuerwehr etc.)
leisure: Freizeitnutzung, wie Sportplätze, Spielplätze, Parks etc.
tourism: Fremdenverkehr
learning: Bildungseinrichtungen

Die Gebäude lassen sich nur aus der tags-Spalte extrahieren, weil es keine Spalte für Gebäude gibt. 
Beim den beiden anderen Importverfahren sieht es anders aus. 

Infos zu den Attributen (tags) in OSM:
http://wiki.openstreetmap.org/wiki/DE:Map_Features

http://wiki.openstreetmap.org/wiki/DE:Map_Features
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OpenStreetmap-Daten nutzen

Alternativen zum Direktimport

Die Visualisierung der direkt importierten OSM-Daten erfordert häufig (z.B. bei der Visualisierung von 
Gebäuden) die Auswertung der tags-Spalte mittels Ähnlichkeitsabfragen (tags like '%building%'). Zudem 

werden Multipolygon-Relationen nicht fehlerfrei übernommen. Alternativen sind der Import über das 
Kommandozeilenprogramm spatialite_osm_map welches die unterschiedlich tag-Kategorien in eigene Layer 

innerhalb einer SpatiaLite-Datenbank separiert, 
so dass es einen Gebäudelayer, einen Landuse-Layer etc. gibt.

oder
der Import in eine PostGis-Datenbank, was sich insbesondere bei größeren Datensätzen wie z.B. OSM-

Daten eines ganzen Landes empfiehlt. Bei diesem Verfahren ist eine PostGIS-Datenbank aufzusetzen, in die 
mittels osm2pgsql (aus QGIS mit der Erweiterung OSM-Tools) Daten importiert werden. 

Sämtliche Relationen werden übernommen und 
die Attributtierung  in logisch strukturierte Spalten übernommen

Erläuterungen zu den Werkzeugen auf den nächsten Seiten!
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OpenStreetmap-Daten nutzen

spatialite_osm_map ist ein Kommandozeilenprogramm aus den Spatialite-Tools, welches eine 
OSM-Datei in eine SpatiaLite-Datenbank importiert.

http://www.gaia-gis.it/gaia-sins/
Download http://www.gaia-gis.it/gaia-sins/windows-bin-x86/

laden Sie spatialite_osm_map.exe herunter

Kopieren Sie die Datei in den Ordner, in welchem sich Ihre OSM-Datei befindet
Öffnen Sie ein Kommandzeilenfenster

(Startmenü < Programme > Zubehör > Eingabeaufforderung)
wechseln Sie mit cd Verzeichnis in das Verzeichnis mit den Daten und dem Programm

anschließend auf der Kommandozeile folgenden Befehl ausführen: 
spatialite_osm_map.exe -o ihredatei.osm -d resultat.sqlite

Die resultierende  SpatiaLite-Datenbank enthält die OSM-Daten sortiert nach Themen
pg_(building, landuse, leisure etc.) = verschiedene Polygonthemen

ln_(highway, waterway etc.) = verschiedene Linienthemen
pt_(place, amenity etc.) = verschiedene Punktthemen

als einzelne Layer einer SpatiaLite-Datenbank

Die einzelnen Layer lassen sich ins QGIS laden und symbolisieren.

Alternativen zum Direktimport: spatialite_osm_map 

http://www.gaia-gis.it/gaia-sins/
http://www.gaia-gis.it/gaia-sins/windows-bin-x86/
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Der Import in eine PostGIS-Datenbank ist Methode der Wahl, wenn Sie große Datenmengen 
(z.B. OSM-Daten eines ganzen Landes) verarbeiten oder sichergehen möchten, dass sämtliche 

Relationen korrekt importiert werden. 
Außerdem setzt PostGis sämtliche tag-keys in eigene Attributspalten um.

Von Nachteil ist, dass Sie zunächst PostGis installieren und 
eine PostGis-Datenbank anlegen müssen. 

Alternativen zum Direktimport: Import in eine PostGis_Datenbank

Schritt 1: PostgreSQL und PostGis installieren
Herunterladen von PostgreSQL

http://www.postgresql.org/download/windows/
Bei der Installation wird das Administrationstool PgAdmin III sowie der Application Stack Builder, mit dem 

Sie wiederun PostGis installieren könne, mitinstalliert.

nach der Installation von PostgreSQL führen Sie den Application Stack Builder aus
Start -> Programme -> PostgreSQL 8.4 -> Application Stack Builder

und wählen unter SpatialExtensions PostGis aus.
Mit der Installation wird eine PostGis-Datenbank angelegt

http://www.postgresql.org/download/windows/
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Alternativen zum Direktimport: Import in eine PostGis_DatenbankAlternativen zum Direktimport: Import in eine PostGis_Datenbank

Schritt 2: Eine neue Datenbank anlegen
Öffnen Sie das Adminstrationsprogramm PgAdmin III 
Start -> Programme -> PostgreSQL 8.4 -> PgAdminIII

und legen Sie eine neue Datenbank an:

Klicken Sie im Objektbrowser: Server < postgis < datenbanken: mit der rechten Maustaste: 
im erscheinenden Kontextmenü: neue Datenbank

Legen Sie die neue Datenbank auf Grundlage der Vorlage template_postgis an

Schritt 3: Datenbank in QGIS anmelden
Öffnen Sie im QGIS den Dialog zum hinzufügen von PostgisDatenbanken

Layer > PostGis-Layer hinzufügen
Klicken Sie auf neu und füllen den Dialog aus:

Bei der Installation der Postgis-Datenbank mussten Sie ein Passwort angeben:

Nehmen Sie die Eintragungen vor und testen Sie die Verbindung

In einem nächsten Schritt importieren Sie die OSM-daten
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Schritt 4b: Erweiterung OSM-Tools in QGIS installieren 
Rufen Sie den Erweiterungsdialog auf:

Erweiterungen > PythonErweiterungen herunterladen > Reiter: Repositorien
Fügen Sie über die Schaltfläche „hinzufügen“ folgende URL hinzu:

http://qgis.dbsgeo.com/
Wechseln Sie zum Reiter Erweiterungen und geben Sie in die Filterzeile OSM ein

Wählen Sie OSM-Tools aus und klicken sie Installieren

Jetzt können Sie endlich Ihre Daten in die PostgisDatenbank importieren

Alternativen zum Direktimport: Import in eine PostGis_DatenbankAlternativen zum Direktimport: Import in eine PostGis_Datenbank

Schritt 4a: osm2pgsql installieren
Zum Import in in die Postgisdatenbank benötigen Sie das kleine Programm

osm2pgsql
http://wiki.openstreetmap.org/wiki/Osm2pgsql#Windows

laden Sie das ZipFile herunter und kopieren Sie die Dateien nach 
C:\Windows\system32 oder nach

C:\Program Files (x86)\Quantum GIS Lisboa\bin

Sie können das Kommandzeilenprogramm über eine QGIS-Erweiterung mit einer
grafischen Benutzeroberfläche benutzen

http://qgis.dbsgeo.com/
http://wiki.openstreetmap.org/wiki/Osm2pgsql#Windows


  

Online-Datenquellen mit QGIS Dr.-Ing. Claas Leiner
Architektur
Stadtplanung
Landschaftsplanung

OpenStreetmap-Daten nutzen

Alternativen zum Direktimport: Import in eine PostGis_DatenbankAlternativen zum Direktimport: Import in eine PostGis_Datenbank

Schritt 5: OSM-daten importieren
Stellen Sie Ihre aktuelle Projektansicht auf das KBS WGS 84

On the Fly-Transformation aktivieren!

Menüaufruf: OSM Tools > Import into PostGIS
Im erscheinenden Dialog nehmen Sie folgenden Einträge vor:

input: Ihre OSM-datei
Database: Im Ausklappmenü die von Ihnen angelegte Datenbank wählen
Slim on mem: Bei größeren Datensätzen anklicken
Projektion: WGS 84 auswählen

Mit „Clip by current bbox“, können Sie den Import auf die Ausdehnung der 
aktuellen QGIS-Ansicht beschränken 

(Nur wenn das Projekt auf WGS 84 eingestellt ist!)

Mit Run starten Sie den Importprozess

Nach dem Importprozess können Sie die Daten über
Layer > PostGis-Layer hinzufügen: Verbinden + hinzufügen

Visualisieren

Folgende Layer gibt es in der PostGis-Datenbank
planet_osm_polygon: Polygone, Flächennutzung, Gebäude etc.
planet_osm_line: Linien, Gewässer, Verkehr etc.
planet_osm_point: Punktinformationen: Behörden, geschäfte etc
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OSM-Datensätze ganzer Länder
http://download.geofabrik.de/osm/europe/germany/

Länderweite OSM-daten beschaffen
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Nach dem erfolgreichen Import der OSM-Daten liegen, jeweils in der PostGis-Datenbank oder als 
SpatiaLite-Dateien Punkt-, Linien und Polygonlayer vor. 

Für die weitere Auseiandersetzung sind Linien (Verkehrswege, Gewässer etc.) und Polygone (Flächennutzung, 
Gebäude etc.) von besonderem Interesse.

Die Sachdaten sind in der Attributtabellen je nach Import unterschiedlich organisiert:
Beim QGIS-Direktimport sind in der Spalte tags sämtliche tags jedes Objektes in der Ursprungssyntax 

dokumentiert, hinzu kommen die Spalten name, place, highway, landuse, waterway, railway, amenity, leisure, 
tourism, learning,  welche  einfache Kategorisierung ermöglichen, die aber häufig nicht verlässlich gefüllt sind!

Die Gebäude lassen sich nur aus der tags-Spalte extrahieren. 

Beim Import über spatialite_osm_map.exe  entstehen für jeden tag-key unterschiedliche Layer (pg_landuse, 
ln_highway etc, welche sich über die Spalte subtype entsprechend den tag-values symbolisieren lassen, 

weiterhin gibt es eine Spalte name mit den Objektnamen

Beim Import in eine PostGis-Datenbank werden sämtliche tag-keys in eigene Attributspalten umgesetzt 
(mehr als 50 keys). So gibt es z.B. die Attributspalten „building“, „landuse“ etc. 

OSM-Daten in QGIS visualisieren

Infos zu den Attributen (tags) in OSM:
http://wiki.openstreetmap.org/wiki/DE:Map_Features

http://wiki.openstreetmap.org/wiki/DE:Map_Features


  

Online-Datenquellen mit QGIS Dr.-Ing. Claas Leiner
Architektur
Stadtplanung
Landschaftsplanung

OpenStreetmap-Daten nutzen

Erläuterung der Attribute nach QGIS-Direktimport

tags: OSM-Attributierung in vollständiger Syntax
name: Eigennamen von Objekten zur Beschriftung (z.B. Staßennamen)
place: Plätze
highway: Kategorisierung von Straßen und Wegen 
landuse: Flächenhafte Landnutzung
waterway: Gewässer
railway: Schienenverkehr
amenity: Öffentliche Einrichtungen, private Dienstleistungen (Kindergarten, Tankstelle, Feuerwehr etc.)
leisure: Freizeitnutzung, wie Sportplätze, Spielplätze, Parks etc.
tourism: Fremdenverkehr
learning: Bildungseinrichtungen

Die Gebäude lassen sich nur aus der tags-Spalte extrahieren, weil es keine Spalte für Gebäude gibt. 
Beim den beiden anderen Importverfahren sieht es anders aus. 

Infos zu den Attributen (tags) in OSM:
http://wiki.openstreetmap.org/wiki/DE:Map_Features

http://wiki.openstreetmap.org/wiki/DE:Map_Features
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OSM-Daten Attribute

Original-tags in der Attributtanelle mach QGIS-Direktimport
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Linien-Layer beschriften
Layer > beschriftung

Eine beschriftete Straßenkarte erzeugen

OSM-Karte aus 
dem Webbrowser
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Linien-Layer beschriften
Layer > beschriftung

Eine beschriftete Straßenkarte erzeugen
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Linien-Layer beschriften
Layer > beschriftung

Eine beschriftete Straßenkarte erzeugen

OSM-Daten mit 
QGIS visualiert
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OSM-Daten in QGIS visualisieren

Infos zu den Attributen (tags) in OSM:
Die inhaltliche Bedeutung der tag-key und Ihrer Werte ist ausführlich auf den 

Seiten des OSM-Projektes dokumentiert:

http://wiki.openstreetmap.org/wiki/DE:Map_Features

Die Umsetzung erfolgt mit Hilfe der regelbasierten Darstellung und der Anwendung von 
Symbolebenen. Mit der regelbasierten Darstellung, lassen sich Kategorien anhand von Regeln 

bestimmen, die sowohl SQL-Abfragen als auch  Kategorisierungen und abgestufte Klassifikationen in 
einer Symbolisierungsvorschrift kombinieren. Das heißt, die Symbolisierung eines Layers kann 

Inhalte verschiedener Attributspalten visualisieren.
Die Vorgehensweise im Detail wird einige Seiten später darggestellt.

Um die OSM-Daten im GIS in eine sinnvolle Karte umzusetzen, ist es notwendig für die 
Kategorisierung mehrere Attributspalten auszuwerten (z.B. landuse, building, amenity, leisure) 

bzw. die tags-Spalte mit Hilfe von Ähnlichkeits-Abfragen direkt auszuwerten.
Diese Vorgehensweise ist bei den Polygonlayern praktisch zwingend, weil es sonst nicht 
möglich ist z.B. Gebäude und Landnutzung gleichzeitig darzustellen (außer sie liegen in 

verschiedenen Layern vor). Will man bei den Linienlayern nur die Straßen und Wege 
visualisieren, reicht die Spalte „highway“

http://wiki.openstreetmap.org/wiki/DE:Map_Features
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Regelbasierte Darstellung

Regelbasiert bedeutet, dass die dargestellten Kategorien 
über eine Attributabfrage definiert werden.

Sie finden die regelbasierte Darstellung über:
Layer > Eigenschaften > Stil (Neue Darstellung): Regelbasierend im Pulldownmenü auswählen

Neue Regel hinzufügen: Schaltfläche hinzufügen klicken:
Hinter Beschriftung: Namen der neuen Regel eintragen (Grünfläche etc.)

Attribut-Abfrageeditor öffnen, um die Regel zu erstellen: Schaltfläche hinter „Filter“
(Siehe Folien zur Bedienung des Attributabfrage-Editors)

Regeln können definiert werden durch:

✗  SQL-Abfragen / Case-Bedingungen (Filter)
✗  Maßstabdefinitionen
✗  Kategorisierungen nach eindeutigen Werte (Regel verfeinern > Kategorien)
✗  Bereiche mit abgestufter Symbolisierung (Bereich hinzufügen)
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Regelbasierte Darstellung nur in der  „Neuen Darstellung“ in QGIS

Zur  „Neuen Darstellung“ 
umschalten

Zur neuen Darstellung muss unter 
Layer > Eigenschaften > Stil 
umgeschaltet werden!
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Regelbasierte Darstellung: Kurzübersicht

Regelbasiert bedeutet, dass die dargestellten Kategorien 
über eine Attributabfrage definiert werden.

Sie finden die regelbasierte Darstellung über:
Layer > Eigenschaften > Stil (Neue Darstellung): Regelbasierend im Pulldownmenü auswählen

Neue Regel hinzufügen: Schaltfläche hinzufügen klicken:
Hinter Beschriftung: Namen der neuen Regel eintragen (Grünfläche etc.)

Ausdrucks-Editor öffnen, um die Regel zu erstellen: Schaltfläche hinter „Filter“
(Siehe folgende Folien)

Symbolisierung
bearbeiten

Symbolisierung
bearbeiten

Symbolebenen
(Siehe Folien 

hinter dem 
Thema 

Abfrageeditor)
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Einzelne Regel:
Besondere Gebäude

Regelbeschriftung

Filter = 
SQL-Abfragung
Case-Bedingung

Berechnung

Ausdruckseditor 
(wie Feldrechnner)

um
Abfragen, Bedingungen

und Berechnungen
zu erstellen

Fertiger Ausdruck

Symbolisierung der
Regel
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Schritt 1: Regel definieren

Doppelklick
zu den 

Regeleigenschaften

Dialog 
Regeleigenschaften

Regelbeschriftung

Filter
(Inhalt der Regel)

Zum 
Symbolisierungsdialog
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Schritt 2: Bedingungen der Regel definieren

 NOT  "landuse"  =  '' 

Ausdrucksseditor
öffnen

Funktionen des
Ausdruckseditors

Fertige
Bedingung

Bsp: Kein leerer Wert in der Spalte landuse
Alle Objekte mit einem Wert

in der Spalte landuse werden angezeigt



  

Online-Datenquellen mit QGIS Dr.-Ing. Claas Leiner
Architektur
Stadtplanung
Landschaftsplanung

OSM-Daten in QGIS regelbasiert visualisieren

Schritt 2a: Bedingungen der Regel definieren

 NOT  "landuse"  =  '' 

Kein leerer Wert in der Spalte landuse
Alle Objekte mit einem Wert

in der Spalte landuse werden angezeigt

Fertige einfache Regel
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Exkurs: SQL Operatoren und Syntax-Regeln zur Formulierung von Bedingungen

Größenvergleiche
Die Operatoren =, >, <, <=, >= sind selbsterklärend

Bsp: Nutz = Wald (Alle Objekte, für die als Attribut der Spalte Nutz der Wert 'Wald' zu finden ist)
Bsp: FL_ha > 12 (Alle Objekte für die Attribut der Spalte FL_ha ein Wert größer als 12 zu finden ist)

Vergleich auf Ähnlichkeiten
Mit dem Operator LIKE Ähnlichkeiten finden 

Bsp: NAME  LIKE  '%Fulda%' (Findet alle Objekte mit 'Fulda' im Namen, z.B. Fulda, Fuldabrück, Rothenburg a. d. Fulda)
(ILIKE brücksichtigt groß- und Kleinschreibung)

Suche über Aufzählungen
Mit dem Operator IN gesuchte Werte aufzählen 

Bsp: OBJEKTART IN ('Wohnbaufläche','Gewerbefläche','Fläche gemischter Nutzung')
Findet alle Objekte, bei denen einer der aufgezählten Werte in der genannten Spalte vorkommt.

Fragen verknüpfen
Mit dem Operator OR, AND und NOT Abfragen über verschiedene Attribute verknüpfen

Bsp: GEMNR   >= 611000 AND  NOT N_KREIS = 'Landkreis Fulda' AND (EINWO_ZA > 10000 OR EinwQKM > 303)
Findet alle Gemeinden mit einer höheren Gemeindenummer als 611000 (RP Kassel), die gleichzeitig nicht zum Landkreis 
Fulda gehören und entweder mehr als 10000 Einwohner oder über eine höhere Bevdichte als 303 Einw je Qkm verfügen.

Grundsätzlich
Textwerte sind in Hochkommas (') einzurahmen / Abfragen lassen sich mit Klammern () strukturieren / Als 

Platzhalter gelten _ für ein beliebiges Zeichen und % für eine unbestimmte  Anzahl beliebiger Zeichen

NoData_Felder finden-Werte finden mit IS NULL
Bsp: GEMNR IS NULL
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Beispiele für Regeln zur Visualisierung anhand der tags-Spalte

(tags LIKE '%leisure%'  OR tags LIKE '%village_green%') AND (NOT tags LIKE '%park%') AND (  NOT tags LIKE '%pitch%') 
AND (  NOT tags LIKE '%playground%')

tags LIKE '%leisure%'  OR tags LIKE '%village_green%') Bedeutet: 
sämtliche Objekte darstellen, bei denen in der Attributspalte „tags“ die Begriffe „leisure“ oder „village_green“ vorkommen.

AND (NOT tags LIKE '%park%') AND (  NOT tags LIKE '%pitch%')  AND (  NOT tags LIKE '%playground%') bedeutet:
Ausgenommen von der Darstellung sind sämtliche Objekte, bei denen in der Attributspalte „tags“ die Begriffe „park“, „pitch“ 

(Sport) oder „playground“ vorkommen

Die Spielplätze werden separat dargestellt mit der Regel: tags LIKE '%playground%'
Freibad und Sportstätten werden mit folgender Regel dargestellt:

landuse = 'recreation_ground'  OR tags LIKE '%pitch%'  AND  (NOT tags LIKE '%athletics%')
Wobei der tag „athletics“ (Stadion) ausgenommen wird, um mit der Regel: tags LIKE '%athletics%' 

das Stadionoval über dem Sportgelände seperat darstellen zu können:

Regeln mit Abfrageeditor erstellen
Beispiel:

Weitere Erläuterungen zum Abfrageeditor:
Siehe folgende Folien

In der dargestellten Regel werden  alle städtischen Grünflächen dargestellt werden, 
die weder Parks, noch Sport- oder Spielplätze sind:

Die tags leisure (Freizeit) und village_green umfassen sämtliche städtischen Grünflächen
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Funktionen zur Erstellung der Ausdrücke:
Berechnen und abfragen

Felder und Werte auswählen

Zu berechnender Ausdruck / Bbedingung

Schnellauswahl wichtiger Operatoren

Exkurs: Funktionen des „Ausdrucksseditors“

Der „Ausdrucksseditors“ ist in seinen Funktionen identisch mit dem Feldrechner
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Exkurs: Beispiele für Ausdrücke
Berechnen einer neuen Attributspalte aus 

vorhandenen Attributen:
Bsp: Bevölkerungsdichte in Einw/qkm

EINWOH_ZA / FLAECHE_HA * 100

Konvertieren von Fließkommazahl zu Ganzzahl
 to int ( Spaltenname)

Konvertieren von Text zu Ganzzahl
 to int ( Spaltenname)

Eintragen von Textwerten in ausgewählte Spalten
Ankreuzen: Nur ausgewählte Objekte aktualisieren

 Feldrechnerausdruck: 'text'
 Feldrechnerausdruck ArcGis: “text“

Fläche der Objekte in QKM
$area / 1000000

Spalten verketten und in eine neue Spalte  schreiben
Spalte 1 II Spalte 2

Spalten verketten

Felder über Case Bedingungen ändern
Case When SQL-Bedingungen when Wert oder Spalte End
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Exkurs: Case-Bedingungen

Werte agregieren über Case-Bedingungen in einem Schritt
Case

When  "OK1234_T" IN ( '2111 Wohnbauflaeche' , '2112 Industrie- und Gewerbeflaeche' , '2113 Flaeche gemischter Nutzung' 
, '2114 Flaeche besonderer funktionaler Praegung' ) 

then 'Siedlung' 
When  "OK1234_T " IN ( '4101 Ackerland', '4102 Gruenland', '4103 Gartenland', '4107 Wald, Forst'  ) 

then 'Land- und Forstwirtschaft' 
End

CASE (Anweisung beginnt)
When (Es folgt die erst Bedingungung)

SQL-Bedingung wie Abfrageeditor
then (Es folgt der Wert oder der Inhalt einer Spalte oder eine Berechnung)

Ein Text- oder Zahlenwert, eine Spalte oder eine Berechnung
When.... (weitere Bedingungen)
then....(Weitere Anweisungen)

END (Anweisung zu Ende)
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Schritt 3: Bedingungen der Regel verfeinern

Kategorisierte Symbolisierung
einer Regel definieren
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Schritt 4: Verfeinerte Regeln weiter bearbeiten

Jede Regel kann einzeln beschriftet und 
symbolisiert werden. Kategorien können
nachträglich zusammengefasst werden:

z.B. Grünland:
„landuse“ in ('meadow', 'greenfield', 'grass')
Als Grünland werden Objekte symbolisiert, die

in der Spalte „landuse“ über eines der gelisteten
Attribute verfügen) 
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Exkurs: Symbologie für Regeln erstellen

Symbolisierung ändern
Mit Doppelklick auf

das Symbol zur 
Symbolauswahl Vorgefertigte Stile

wählen

Stile speichern
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Neuer Farbverlauf „Zufallsfarben“ für kategorisierte Darstellung

Im Eigenschaftendialog 
Layer > Eigenschaften > Stil (kategorisiert oder abgestuft): Ausklappmenü Farbverlauf > „neuer Farbverlauf“

oder über: Einstellungen > Stilmanager > Reiter: Farbverlauf: Schaltfläche: hinzufügen
können Sie neue Farbverläufe erzeugen.

Mit Zufällig erzeugen Sie eine zufällige Abfolge von Farben für die Erstkategorisierung in möglichst 
unterschiedlichen Farben:

 Farbtonbereich
hier: gesamt

 Sättigung
hier: volle Sättigung =

(keine Grautöne)

Anzahl der möglichen
Werte

Klassen des 
Farbverlaufs
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Exkurs: Symbolisierung QGIS

Polygon-Symbolauswahl in der  „Neuen Darstellung“ von QGIS

 Eigenschaften des 
Symbols bearbeiten

  Symbol zum 
Stilkatalog hinzufügen

 Fertiges Symbol aus
dem Stilmanager

auswählen

 Zur Bearbeitung
mit Doppelklick
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Exkurs: Symbolisierung gestalten in QGIS

Polygon-Symboleigenschaften in der  „Neuen Darstellung“ von QGIS

Polygonsymbol aus zwei Symbollayern
Eigenschaften: Einfache Füllung

 Liste der 
Symbollayer

 Symbollayer 
entfernen

 Symbollayer 
hinzufügen

 Vertikale Anordnung
der Symbollayer

bearbeiten 
 Resultierendes

Symbol

 Symbollayertyp:
Fünf verschiedene 

Fülltypen sind wählbar

 Darstellungs-Eigenschaften
für „Einfache Füllung“ 

bearbeiten

Komplexe Symbole lassen 
sich aus mehreren Einzel-
symbolen (Symbollayern) 
aufbauen! Dabei können 
verschiedene Füllungstypen 
(SVG, Linienmuster etc.) 
verwendet werden.

In diesem Beispiel:

Eine SVG-Grafik mit 
Baumsymbolen liegt 
über einer einfachen 

Farbfüllung.
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Exkurs: Symbolisierung gestalten in QGIS

Polygon-Symboleigenschaften in der  „Neuen Darstellung“ von QGIS

Polygonsymbol aus 3 Symbollayern (Einfach, Linienmuster, zentriertes SVG-Symbol)
Eigenschaften: Linienmusterfüllung

 Liste der 
Symbollayer

 Symbollayer 
entfernen

 Symbollayer 
hinzufügen

 Vertikale Anordnung
der Symbollayer

bearbeiten 

 Resultierendes
Symbol

Art der Füllung auswählen

Linienmuster bearbeiten

Rand bearbeiten
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Exkurs: Symbolisierung gestalten in QGIS

Symboleigenschaften in der  „Neuen Darstellung“ von QGIS

Polygonsymbol aus zwei Symbollayern (Einfach, SVG-Füllung)
Eigenschaften: SVG-Füllung

 Liste der 
Symbollayer

 Symbollayer 
entfernen

 Symbollayer 
hinzufügen

 Vertikale Anordnung
der Symbollayer

bearbeiten 

 Resultierendes
Symbol

Art der Füllung auswählen

 SVG-Grafik aus 
der Liste wählen.

(Unter Einstellung > Optionen >
SVG lassen sich Ordner mit 
SVG-Grafiken hinzufügen)

 SVG-Datei direkt wählen

Rand bearbeiten
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Exkurs: Symbolisierung gestalten in QGIS mit SVG-Grafiken

Exkurs: SVG-Grafiken erstellen und für QGIS zur verfügung stellen

SVG-Grafiken lassen sich in vielen Vektorgrafik-Programmen erzeugen. 
Z.B. beherrschen Inkscape und Illustrator den SVG-Export. 

Die Firefox-Erweiterung SVG-Edit bietet einenn einfachen SVG-Editor
http://code.google.com/p/svg-edit/

https://svg-edit.googlecode.com/files/svg-edit-2.6.zip
http://svg-edit.googlecode.com/svn/branches/2.6/editor/svg-editor.html

Einfach ist auch der Export von SVG aus dem Libre(OpenOffic)e-Präsentationsmodul „ Impress“.

Impress starten, und Seitengröße 5 X 5 cm auswählen.
Mit den Zeichenwerkzeugen eine einfache Grafik erzeugen
Über Datei > Exportieren > SVG eine SVG-Grafik erzeugen

SVG-Ordner in QGIS anmelden

Die eigenen SVG-Grafiken in einem oder mehreren thematischen Ordnern speichern.
Über Einstellungen > Optionen > Darstellung u. SVG > SVG-Pfade

lassen sich die Grafiken in den ausgewählten Ordner der SVG-Auswahl in QGIS hinzufügen

http://code.google.com/p/svg-edit/
https://svg-edit.googlecode.com/files/svg-edit-2.6.zip
http://svg-edit.googlecode.com/svn/branches/2.6/editor/svg-editor.html
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OSM-Daten in QGIS regelbasiert visualisieren

Schritt 5: Mit Hilfe von Symbolebenen die vertikale Visualisierung der Objekte steuern

In den „Layereigenschaften“ auf die Schaltfläche „Zeichenreihenfolge“ klicken

Da es im OSM-Datenmodell sich überschneidende Polygone gibt (Ein Gewässer im Park) und die Anzeigereihenfolge 
manchmal nicht den Erwartungen entspricht 

(Das Gewässer liegt unter dem Park – verschwindet also unter der Parksignatur), 
muss die vertikale Reihenfolge der visualisierten Regeln bzw. Kategorien festgelegt werden:
Die Regel „Gewässerdarstellung“ ist oberhalb der Regel „Parkdarstellung“ zu visualisieren.

Je höher die Ziffer für die einzelne Symbolebene, 
desto höher die Priorität:

Das blaue Symbol für „Gewässer“ hat mit „4“ eine 
höhere Priorität als die „Grünflächen“ mit dem Wert 
„3“. Deswegen werden die Gewässer  über den 
Grünflächen angezeigt.  Ansonsten liegen die 
Gewässer im Beispieldatensatz  unter den 
Grünflächen!

Es können auch genau definierte Prioritäten für 
einzelne „Symbollayer“ eines Kategoriesymbols 
festgelegt werden, was für eine gute Darstellung 
des Straßenlayers wichtig ist!
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OSM-Daten in QGIS regelbasiert visualisieren

Schritt 5: Mit Hilfe von Symbolebenen die vertikale Visualisierung der Objekte steuern

 NOT  "landuse"  =  '' 

In den „Layereigenschaften“ auf die Schaltfläche „Zeichenreihenfolge“ klicken
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OSM-Daten in QGIS regelbasiert visualisieren

Schritt 9: Mit Hilfe von Symbolebenen die vertikale Visualisierung der Objekte steuern

In den „Layereigenschaften“ auf die Schaltfläche „Zeichenreihenfolge“ klicken

Gebäude mit höherer Ziffer als 
Flächennutzung: liegen immer oberhalb
Gebäude mit höherer Ziffer als 
Flächennutzung: liegen immer oberhalb

Kindergarten liegt immer oberhalb

Landnutzung: Symbol aus zwei 

Symbollayern
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OSM-Daten in QGIS regelbasiert visualisieren

Fertige Regelbasierte Darstellung des OSM-Polygonlayers

 NOT  "landuse"  =  '' 

Gebäude mit besonderer Bedeutung (Schulen etc.) 
werden über eine Ähnlichkeitsabfrage definiert, die 

sich auf den Begriff „buildings“ in der tags.Spalte und
Werte in der Spalte „name“ bezieht. 

Einfache Kategorisierungen der 
Spalte landuse, hier Wohngebiet

Auflistung mit der SQL-Funktion
„IN“

hier: Grünland

Differenzierte Auflistung von 
Sportflächen über Ähnlichkeitsabfragen

(LIKE)
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OpenStreetmap-Daten visualisieren

Die OSM-Shapefiles lassen sich kategorisiert darstellen:

Beim Linienlayer ist die Attributspalte „Highway“ maßgeblich

Visualisierung in „neuer Darstellung“

Visualisierung Linien-Shapefile

Layer > Eigenschaften > Stil (Neue Darstellung): kategorisiert im Pulldownmenü auswählen
Spalte: Highway

Doppelklick!

Eigenschaften

Symbollayer hinzufügen 
und anordnen!

Hier Straße aus weißer 
und schwarzer Linie!

Symbolebenen:
Reihenfolge der Symbollayer 

festlegen!
siehe Nächste Seite

Klassifizieren!
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OpenStreetmap-Daten visualisieren

Symbolebenen verwenden (Schaltfläche „Symbolebenen“ im Darstellungsdialog!)

Mit Hilfe von Symbolebenen lassen sich grafisch 
korrekte Straßendarstellungen, auch bei aus 
mehreren Symbollayern visualisierten Linien-

Shapes erstellen. Es gibt keine Unterbrechungen 
an Segmentgrenzen und fließende Anschlüsse!

 

Die Symbollayer mit dem höheren Ziffernwert, liegen über den 
Symbollayern mit dem niedrigeren Ziffernwert. 

Somit liegen die schwarzen Autobahnränder immer unterhalb!

Ohne
Symbolebenen!

Mit
Symbolebenen!
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Symbolisierung von Linienlayern

Einen Linienlayer als kategorisierte Straßenkarte darstellen (OSM-Daten aus Kassel)
Layer > Eigenschaften > Stil  kategorisiert im Pulldownmenü auswählen Spalte: Highway

Stil 
„kategorisiert“

Symbol
bearbeiten

„Doppelklick“

Attributspalte
„Highway“

Ändern des
Symbols

Aufbau aus 3 Layern,
Schwarz -dünn
gelb-schmaler
schwarz-breit

gespeicherte
Symbole
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Symbolisierung von Linienlayern

Problem des unkontrollierten Überlappens von Symbollayern!

Abgrenzungen des 
Segmentabschnitte 

werden sichtbar
„gestückelte Darstellung“

Lösung:
Symbolebenen 
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Symbolisierung von Linienlayern

Mit Symbolebenen eine kartographisch ansprechende Darstellung.
Aktivierte Symbolebenen:

Für jeden Symbollayer wird festgelegt, 
mit welcher Priorität er gezeichnet wird,

also sichtbar ist, wenn die symbolisierten
Objekte übereinanderliegen.

Je höher die Ziffer, desto höher die Priorität!
Es gibt keine Unterbrechungen an 

Segmentgrenzen und fließende Anschlüsse!
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Symbolisierung von Linienlayern

Problem: Maßstabsveränderung!
Beim herauszoomen 

wachsen die Straßen zu 
amorphen Flächen 

zusammen.

Lösungsmöglichkeit 1:
Symbolgröße in 

Karteneinheiten statt in mm.
Dabei Breite modifizieren!
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Symbolisierung von Linienlayern

Gezoomt  mit in Karteneinheiten festgelegten Symbolbreiten 

Umstellung von mm auf 
Karteneinheiten für ein 

einzelnes Symbol
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Symbolisierung von Linienlayern

Gezoomt  mit in Karteneinheiten festgelegten Symbolbreiten 
Ausgabeeinheit (mm oder 

Karteneinheiten) und Breite 
lässt sich mit rechter Maustaste 

auch direkt in den 
Eigenschaften ändern.
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Symbolisierung von Linienlayern

Gezoomt  mit in Karteneinheiten festgelegten Symbolbreiten 

Lösungsmöglichkeit 2:
Maßstabsabhängige 

Darstellung
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Straßenbeschriftung „Intelligent“

Layer > Beschriftung 

OpenStreetmap-Daten visualisieren
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OpenStreetmap-Daten visualisieren

Die Basiseinstellungen im intelligente Labelling lassen sich im Reiter 
Beschriftungseinstellungen festlegen

Grundlegende Einstellungen im intelligenten labeling

Beschriftung
aktivieren

Attributspalte für
Labeling auswählen

Einstellungen zur
Schriftformatierung

Schrift wird zur 
besseren Sichtbarkeit

weiß oder farbig
hinterlegt 

Hier kann ein
Maßstabsbereich festgelegt

werden, in welchem die
Beschriftung angezeigt wird 
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OpenStreetmap-Daten visualisieren

Die automatische Platzierung im intelligente Labelling lässt sich im Reiter 
Erweitert > Platzierung einstellen

Automatische Platzierung

Beschriftung
aktivieren

Attributspalte für
Labeling auswählen

Reiter:
erweiterte

Platzierung

Beschriftung
entlang gebogener

Linien möglich

Nicht jeder
Linienabschnitt
wird beschriftet
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OpenStreetmap-Daten nutzen

Gebäude extrahieren
Die schon bei der „regelbasierten Darstellung“ verwendeten Attributabfragen lassen sich nutzen, um 

einzelne thematische Ebenen, wie z.B. die Gebäude als eigene Layer zu speichern!
Über

Layer > Attributtabelle öffnen > erweiterte Suche
gelangt man zum Abfrageeditor

Einzelne Themen aus dem Polygonlayer extrahieren

Syntax: 
tags LIKE '%addr%' OR tags LIKE '%building%'

Auswahl über Ähnlichkeitssuche in der Spalte „tags“ möglich
Gebäude lassen sich z.B. über die tags „building“ und „addr“ finden
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OpenStreetmap-Daten nutzen

Layer gegeneinander ausstanzen
Vektor > Geoverarbeitungswerkzeuge > Differenz

z.B. Gebäude aus einem anderen Layer ausstanzen

Dort, wo vorher die Gebäude waren, sind anschließend Löcher

Layer mit eindeutigen Flächenzuordnungen erzeugen

Im OSM-Modell überschneiden sich Flächenzuordnungen ähnlich wie im ATKIS-DLM
Beispiel:

Ein Gebäudepolygon („building = Yes“) liegt über einem Polygon mit der Zuweisung „leisure=Park“ und 
dies wiederum über einem Polygon mit der Zuweisung "landuse"="residential" (Wohngebiet).

Um eine eindeutige Flächenzuordnung zu erreichen, weil man z.B. die nicht von Gebäuden überbaute 
Fläche eines Wohngebiets ermitteln möchte, kann die vorher ausgewählten Teilflächen (Gebäude) aus 

dem Gebiet (Wohngebiet) ausstanzen.

Eingabevektorlayer: Der Layer, in welchen die Löcher gestanzt werden sollen.
Differenzlayer: Die Objekte dieses Layer stanzen die Löcher
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OpenStreetmap-Daten nutzen

Layer mit eindeutigen Flächenzuordnungen erzeugen

Layer zusammenführen
Möchte man aus den einzelnen zugeschnittenen Layern wieder einen Gesamtlayer erstellen, der dann 

keine sich überschneidenden Polygone enthält, so verwendet man das Werkzeug:
Vektor > Datenmanagementwerkzeuge > Shapedateien zusammenführen
Es lassen sich sämtliche Shapes eines Ordners oder einzeln ausgewählte Shapes,

 zu einem neuen Shape zusammenführen.

Mit Hilfe eines solchen Shapes lassen sich dann beipielsweise präzise Flächenbilanzierungen durchführen
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SRTM-Daten nutzen

Im Rahmen des Shuttle Radar Topography Mission (SRTM) erfasste Höhendaten mit einer Auflösung von 100 m.
Download:

http://netgis.geo.uw.edu.pl/srtm/Europe/ oder
http://dds.cr.usgs.gov/srtm/version2_1/SRTM3/Eurasia/

SRTM-Daten finden

Die Daten liegen als gezipte HGT-Daten vor und können nach dem entpacken über 
Layer > Rasterlayer hinzufügen direkt ins QGIS geladen werden.

 Unter Layer > Eigenschaften im Ausklappmenü „Kontrastverbesserung“ „Strecken auf MinMax)
Auch GRASS kann die Daten direkt verarbeiten.

Die Daten liegen im geographischen Koordinatensystem WGS 84 vor

Die Bezeichnung der Dateien ergibt sich aus den geographischen Koordinaten
N51E008.hgt.zip bedeutet

Die untere linke Ecke des Bildausschnitts (der untere linke Pixel!) liegt auf 51° Nord geographische Breite und 8° 
Ost (East) geographische Länge. 

Die Ausdehnung der einzelnen Kacheln beträgt in jede Richtung ein Bogengrad. 

Mit Hilfe der GDAL-Tools (Menü Raster) lassen sich die Daten ins Geotiff-Format konvertieren, 
zusammenschweißen und in ein metrisches Koordinatensystem (GK3, ETRS 89) umprojizieren.

Siehe Folien 9 (Luftbilder konvertieren)

Auf den nächsten Seiten: Folien zur Visualisierung von Rasterdaten!
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SRTM-Daten visualisieren

 Unter Layer > Eigenschaften im Ausklappmenü „Kontrastverbesserung“ „Strecken auf MinMax)

Einfache Graustufendarstellung

 

Farbabbildung 
Graustufen

Farbabbildung umkehren, dann
repräsentieren dunkle  Farben

höhere Bereiche

Kontrastspreizung aktivieren, 
ansonsten sind keine Strukturen

zu erkennen!
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SRTM-Daten visualisieren

Ein-Kanal-Rasterdaten (z.b 255 Farben / Graustufen) können in 
Graustufen oder als klassifizierte Farbkarte dargestellt werden

  

Die Darstellungsfarbe jedes Farbwertes kann individuell gewählt
und  individuell transparent gestellt werden.

Farbreduzierte (indizierte)  Rasterdaten (Ein-Kanal = bis zu 256 Farben)

Wir auch als Darstellung mit indizierten Farben bezeichnet. Die Farben werden nicht 
direkt, sondern als Verweise auf eine Farbtabelle (Index) gespeichert.

Dies führt bei wenigen Farben zu geringen Dateigrößen

Dies trifft auf die SRTM-Daten zu!

Thematische Darstellung von Rasterdaten ist möglich
(Höhendaten, Topographische Karten etc.)
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SRTM-Daten visualisieren

Darstellung in Graustufen oder als Farbkarte

Grundsätzlich lassen sich die Pixelwerte 
indizierter Rasterdaten als durchgehende 

Graustufenabfolge oder als Abfolge 
individuelle auswählbarer Farbwerte 

(Farbkarte) darstellen. 

Einstellungen unter Layereigenschaften > Darstellung

Einstellung zur Kontrastverbesserung 
von Graustufenbildern. 

Wichtig bei Interpolierte Höhenrastern

Einstellung der Farbabbildung
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SRTM-Daten visualisieren

Darstellung als Farbkarte

Nachdem Sie unter Layer > Eigenschaften > Darstellung > Farbabbildung
„Farbkarte“ gewählt haben, können Sie in der Rubrik „Farbkarte“ verschiedene Einstellungen vornehmen.

Beispiel: Eine Topographische Karte mit insgesamt 8 verschiedenen Farbwerten (0 - 7) 

Pixelwert (bei 8 Werten 0 – 7). 
Es ist auch möglich,

 bei vielen Werten eine interpolierte 
Darstellung umzusetzen.

Weiterhin ist das Löschen 
einzelner Werte möglich

Farben der einzelnen 
Werte. Mit einem Doppelklick
auf die Farbbalken, lassen 

sich die Farben beliebig
ändern!

Laden und speichern von
Farbtabellen als *.txt.

So lassen sich Darstellungs-
vorschriften einfach 

übertragen.
(siehe nächste Seite)

Nach einem Doppelklick
hinter eine Farbe, lässt sich

ein Text einfügen. Per 
Screenshot können Sie aus 

Farbbalken und Beschriftung 
eine Rasterlegende für

das Karten-Layout erzeugen!
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SRTM-Daten visualisieren

Sicherung der Darstellung in einer Textdatei

Über „Farbabbildung in Datei speichern“, lassen sich die 
Darstellungsvorschriften als Textdatei speichern 

(siehe vorherige Seite)

Wert R G B Beschriftung
0 0 0 0 255 Color entry 1
1 255 255 255 255 Color entry 2
2 191 242 128 255 Color entry 3
3 204 102 102 255 Color entry 4
4 191 255 255 255 Color entry 5
5 0 204 0 255 Color entry 6
6 0 128 255 255 Color entry 7
7 255 179 0 255 Color entry 8

Farbtabelle im Textformat

Resultierende Darstellung

Die Werte für Rot, Grün 
und Blau werden in 
üblicherweise als 

Zahlenwerte zwischen 0 
und 255 gespeichert.
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SRTM-Daten visualisieren

Klassifizierte Farbkarte in QGIS

 

Anzahl der Klassen angeben
mit Schaltfläche „Klassifzieren“

Farbkarte generieren

Farbabbildung erscheint nach 
Klassifikation immer in rot-blau-Abstufung. 

Änderung manuell  möglich.
Es können keine Farbverläufe vorab

ausgewählt werden.

Klassengrenzen, Farbe und Beschriftung
lassen sich manuell ändern. Mit einem

Doppelklick auf die Werte, lassen sich die
Klassengrenzen bearbeiten. Über einen

Doppelklick auf die Farbbalken kommen 
Sie in den Dialog zum Farben einstellen.

Reiter „Farbkarte“ - Hier erreichen Sie
diesen Dialog!
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SRTM-Daten visualisieren

Klassifizierte Farbkarten in QGIS

 

Klassifzierte Farbkarte in QGIS mit 1-Band Raster Colour-Table Erweiterung darstellen

Darzustellendes Raster

Python-Erweiterung herunterladen
Rasterlayer im Inhaltsverzeichnis auswählen und Erweiterung

über Erweiterungen > Raster Colours >1-Band Raster Colour-Table Erweiterung V1.X starten 

Sie können anschließend aus vielen verschiedenen Farbverläufen auswählen

Textdatei in welcher die Farbtabelle gespeichert wird.
Farbtabelle lässt sich im Dialog Farbkarte laden

Hier lassen sich unterschiedliche
Farbverläufe für die klassifizierte

Darstellung der Farbkarte auswählen.

Klassifikationsmethode
auswählen 

(statistische Verfahren)

Farbtabelle in Textdatei schreiben
(siehe oben)Erstellte Farbtabelle auswählen,

nach der das Raster dargestellt wird. 
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SRTM-Daten visualisieren

Transparenz für einzelne Farben einstellen

Unter Layer > Eigenschaften > Transparenz können Sie die Transparenz eines
Rasterlayers gobal oder für jeden Pixelwert einzeln einstellen

In diesem Beispiel sind in der TK25 sämtliche Farbwerte außer 3 (braun), 4 (hellblau) und 6 (dunkelblau)
zu 100 % transparent gestellt worden, so dass nur Gewässer und Höhenlinien angezeigt werden! 

Hier kann manuell
ein Pixelwert eingetragen

werden.

Farbwerte, welche
transparent dargestellt

werden sollen.

Einstellung der 
globalen Transparenz Prozentuale Transparenz

der eingetragenen
Pixelwerte

Zeile zur Eintragung
eines weiteren Pixelwertes

hinzufügen

Zeile mit Pixelwert löschen

Farbwert aus Kartenansicht
abgreifen

 Sie können die 
Werte manuell 

eintragen oder aus 
der Kartenansicht 

abgreifen.
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Schattenrelief  (Hillshade) erzeugen

 

Vorgehensweise unter ArcGis 
 

ArcToolbox >3D-Analyst (SpatialAnalyst) > Surface > Hillshade
Deutsch: ArcToolbox >3D-Analyst (SpatialAnalyst)  >Rasteroberfläche > Schummerung

Vorgehensweise unter QGIS

Raster > Analyse> DHM: Modus = Schummerung oder
Erweiterungen > GRASS > GRASS-Werkzeu. > Raster > Räumliche Analysen>Geländeanalyse>r.shaded.relief

Oder: WXPython-Grass: Raster >Reliefanalyse >Reliefschattierungen (r.shaded.relief)

Ein Schattenrelief stellt die Höhenformen der Landschaft plastisch dar. Hangneigungen 
werden aus dem Höhenraster errechnet und über Schattierungseffekte visualisiert

Schattenreliefs lassen sich transparent über andere Karten legen, um Schummerungseffekte zu erreichen.
Die Darstellung kann überhöht werden, um das Relief deutlicher abzubilden. 

Die virtuelle Sonnenhöhe und der virtuelle Sonnenstand sind einstellbar.

Ausgangsdatei ist jeweils das vorher erstellte interpolierte Höhenraster!
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Schummerungskarte aus Schattenrelief erzeugen

 

Schattenrelief
Schattenrelief mit 60% Transparenz über klassifiziert

dargestellten interpolierten Höhenraster
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Vektorhöhenlinien erzeugen

 

Vorgehensweise unter ArcGis 
 

ArcToolbox3D > Rasteroberfläche > Konturlinie
SpatialAnalystTools > Surface > Contour List

Vorgehensweise unter QGIS

Raster > Extraktion >Kontur (gdal_contour) oder
Erw. > GRASS > GRASS-Werk. >Raster >Räumliche Analysen > Oberflächenverwaltung> Vektorkonturlinien 

Aus dem interpolierten Höhenraster lassen sich Vektorhöhenlinien als Linienshapefile extrahieren. 
Das GIS errechnet aus dem Höhenraster Linien gleicher Höhe und speichert Sie als Shapefile mit 

der jeweiligen Höhe als Attributwert ab. 
Höhenabstand und Intervall der Linien ist beliebig einstellbar.

Höhenlinien lassen sich gut zur dezenten Visualisierung von Höhen in thematischen und 
topographischen Karten verwenden, da die Shapefiles einfach in Strichdicke und Farbe zu 

visualisieren sind.

Greift aus das Programm gdal_contour
aus den GDAL-Tools zurück, die

mit QGIS installiert werden.
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Dialog Beispiel aus QGIS

Interpoliertes Höhenraster
als Eingabedatei

Menüaufruf: Raster > Kontur (gdal_contour)

Ausgabeverzeichnis für das 
Shapefile mit Namen Contour.shp

Höhenabstand der Höhenlinien
in Meter

Name der Attributspalte mit
den Höhenwerten

Resultierender
GDAL-Kommandozeilenbefehl

Höhenlinien mit Beschriftung
überklassifzierten Höhenraster
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